Adobe Acrobat and Reader JavaScript Vulnerability

acrobat_logoAdobe issued a warning about a buffer overflow vulnerability in all recent versions of Acrobat Reader and Adobe Acrobat. Attackers can inject malicious code into computers with specially prepared PDF documents.

While Adobe announces an Update for the affected software for the 12th May, users of Adobe Reader and Acrobat should till then disable JavaScript support in their products. Adobe recommends following procedure:

1. Launch Acrobat or Adobe Reader.
2. Select Edit>Preferences
3. Select the JavaScript Category
4. Uncheck the ‘Enable Acrobat JavaScript’ option
5. Click OK.

Dirk Knop
Technical Editor